Code run failing

For most of the courses i have taken where there is a practice section to run and learn, the executon/run is failing.

Type your question above this line.


Hello @Christopher_Jeyaraj

I ran the application in the lesson you have mentioned and code is compiling and running successfully. Please make sure you are following the step by step instructions provided inside the lesson. First you have to run the application. After it has successfully compiled, run the following commands in order as mentioned in the lesson:

kubectl get pods
kubectl port-forward --address nginx 3000:80

Run the commands inside the application terminal provided and then click on the link present under the SPA widget.

Hope this helps!


when I run the application it seems to be always failing at the step Pulling the image failed. I have attached the screenshot.


Thank you for your feedback.

Please clear your browser cache and then refresh/reopen this lesson. This will fix the issue.

I cleared the browser cache and tried it is still failing in the same step. I tried with both Edge as well as Chrome but the result is the same, even tried with different laptops but no luck.