The constructor use its parameters and assigned this.num1 = num1; and this.num2 = num2;
Each method called for this.num1 instead of simply num1. I understand the constructor’s parameters had the same name as the fields, so that’s why we are using this.num1 vs num1.
However, is it best practice to name the constructor parameters something different than the field variables? This would allow us to not have to put this.num1 and this.num2 in every method (repetitive).